const regex = /^(?=.*?[0-9])(?=.*?[a-z])(?=.*?[A-Z])(?=.*?[^\w\s]).{8,20}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*?[0-9])(?=.*?[a-z])(?=.*?[A-Z])(?=.*?[^\\w\\s]).{8,20}$', '')
const str = `Tekken.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}