package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)[0-9a-z !]*`)
var str = `Hello world !
Hello world !
Hello world !`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}