re = /^[a-z0-9][-a-z0-9.!#$%&'*+-=?^_`{|}~\/]+@([-a-z0-9]+\.)+[a-z]{2,5}$/
str = 'cuongdecheiitmbkav@yahoo.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end