const regex = /(["'])((?:(?=(?:\\)*)\\.|.)*?)\1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(["\'])((?:(?=(?:\\\\)*)\\\\.|.)*?)\\1', 'gm')
const str = `" RegExp to match quotes "
' Supports escapin\\' '
" This is selected \\\\" this is not
' Works with JS RegExp '
"You can also get the quote type used"
"How it works"
"------------"
' (["\\']) Matches a " or a \\' and stores it in \\1'
' ( starts \\2'
' (?: starts a non-capturing group'
' (?=(?:\\\\)*) Will check if there is an odd amount of \\ '
' \\\\. will escape / ignore it '
' |. will never mind it if there\\'s an even amount '
' )*? will close the non-capturing group and repeat it'
' \\1 will make it close with the quote selected in \\1'
"Flags:"
"------"
" g: global, selects multiple times "`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}