$re = '/([1-9]{0,1}[0-9]{1,6})/';
$str = '504';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);