$re = '/[^0-9]+/';
$str = '9(35) 3465-4553';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;