re = /<[^<]*\n<[^<]*(?<=<!-- )Links -->\n[^>]*>/m
str = '<!-- -->
<!-- Links -->
<!-- -->'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end