import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<li><a href=\"\" target=\"_blank\">[\\n](.*?)[\\n](https?:\\/\\/(?:www\\.|(?!www))[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\\.[^\\s]{2,}|www\\.[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\\.[^\\s]{2,}|https?:\\/\\/(?:www\\.|(?!www))[a-zA-Z0-9]+\\.[^\\s]{2,}|www\\.[a-zA-Z0-9]+\\.[^\\s]{2,})[\\n]<\\/a><\\/li>";
final String string = "<li><a href=\"\" target=\"_blank\">\n"
+ "Best Buy – Mount Laurel, NJ – Robbery\n"
+ "https://patch.com/new-jersey/cinnaminson/7-3k-electronics-stolen-burlington-co-store-suspect-sought\n"
+ "</a></li>\n"
+ "<li><a href=\"\" target=\"_blank\">\n"
+ "C-Store- Yuma, AZ – Armed Robbery\n"
+ "https://arizonadailyindependent.com/2023/02/14/yuma-county-sheriffs-deputies-make-robbery-arrest/\n"
+ "</a></li>\n"
+ "<li><a href=\"\" target=\"_blank\">\n"
+ "C-Store – Jasper, TX – Armed Robbery\n"
+ "https://www.kjas.com/news/local_news/article_c5a5133a-ace7-11ed-9a1b-630ed466fb7f.html\n"
+ "</a></li>\n"
+ "<li><a href=\"\" target=\"_blank\">\n"
+ "C-Store – Colorado Springs, CO – Armed Robbery\n"
+ "https://gazette.com/news/crime/shots-fired-during-attempted-armed-robbery-in-east-colorado-springs/article_96f7de40-ac70-11ed-ad96-2b1db289229e.html\n"
+ "</a></li>\n"
+ "<li><a href=\"\" target=\"_blank\">\n"
+ "C-Store – Houston, TX – Armed Robbery\n"
+ "https://mobile.twitter.com/KHOU/status/1625379198322806785\n"
+ "</a></li>\n"
+ "<li><a href=\"\" target=\"_blank\">\n"
+ "C-Store – Kanawha County, WV – Armed Robbery\n"
+ "https://www.wsaz.com/2023/02/15/deputies-investigating-armed-robbery-gas-station/\n"
+ "</a></li>\n"
+ "<li><a href=\"\" target=\"_blank\">\n"
+ "Department – Cleveland, OH – Robbery\n"
+ "https://www.cleveland.com/community/2023/02/man-already-banned-from-returning-to-beachwood-place-until-2028-arrested-for-stealing-mall-merchandise-beachwood-police-blotter.html\n"
+ "</a></li>\n"
+ "<li><a href=\"\" target=\"_blank\">\n"
+ "Dollar – Akron, OH – Armed Robbery\n"
+ "https://www.cleveland.com/crime/2023/02/akron-police-investigate-armed-robbery-of-dollar-general-clerk.html\n"
+ "</a></li>\n"
+ "<li><a href=\"\" target=\"_blank\">\n"
+ "Grocery – Showell, MD – Armed Robbery\n"
+ "https://www.wrde.com/news/troopers-ask-for-help-in-identifying-man-suspected-in-showell-armed-robbery/article_c2e57e92-ac78-11ed-a628-7fba37176075.html\n"
+ "</a></li>\n"
+ "<li><a href=\"\" target=\"_blank\">\n"
+ "Guns – Lansing, IL – Burglary\n"
+ "https://www.fox32chicago.com/news/police-seek-smash-and-grab-crew-who-burglarized-canada-goose-lansing-gun-store\n"
+ "</a></li>\n"
+ "<li><a href=\"\" target=\"_blank\">\n"
+ "Hardware – Tulsa, OK – Robbery\n"
+ "https://www.fox23.com/news/video-three-men-arrested-stealing-thousands-dollars-flooring-tile/3708187a-4784-4ea5-b9c7-04971b6315dc/\n"
+ "</a></li>\n"
+ "<li><a href=\"\" target=\"_blank\">\n"
+ "Marijuana – Los Angeles, CA – Burglary\n"
+ "https://www.cbsnews.com/losangeles/video/fairfax-dispensary-burglary-foiled-by-lapd-response/\n"
+ "</a></li>\n"
+ "<li><a href=\"\" target=\"_blank\">\n"
+ "Marijuana – Lynnwood, WA – Burglary\n"
+ "https://ustimespost.com/thieves-ram-truck-into-lynnwood-pot-shop-in-attempted-atm-robbery/\n"
+ "</a></li>\n"
+ "<li><a href=\"\" target=\"_blank\">\n"
+ "Marijuana – New York, NY – Robbery\n"
+ "https://www.audacy.com/1010wins/news/local/suspect-spray-manhattan-smoke-shop-worker-steal-usd300-in-weed\n"
+ "</a></li>\n"
+ "<li><a href=\"\" target=\"_blank\">\n"
+ "Marijuana - Los Angeles, CA – Burglary \n"
+ "https://www.cbsnews.com/losangeles/video/fairfax-dispensary-burglary-foiled-by-lapd-response/\n"
+ "</a></li>\n"
+ "<li><a href=\"\" target=\"_blank\">\n"
+ "Marijuana – Moore, OK – Burglary\n"
+ "https://kfor.com/news/local/two-in-custody-after-burglary-of-oklahoma-dispensary/\n"
+ "</a></li>\n"
+ "<li><a href=\"\" target=\"_blank\">\n"
+ "Pawn – Lewisville, TX – Armed Robbery / Owner killed\n"
+ "https://www.crosstimbersgazette.com/2023/02/14/lewisville-police-seeking-3-suspects-in-capital-murder-of-pawn-shop-owner/\n"
+ "</a></li>\n"
+ "<li><a href=\"\" target=\"_blank\">\n"
+ "Pharmacy – Chautauqua County, NY – Robbery\n"
+ "https://www.observertoday.com/news/top-stories/2023/02/robbery-suspect-identified-by-silver-creek-cameras/\n"
+ "</a></li>\n"
+ "<li><a href=\"\" target=\"_blank\">\n"
+ "Restaurant – Oakland, CA – Robbery\n"
+ "https://deleciousfood.com/oakland-restaurant-manager-details-robbery-similar-to-the-one-that-killed-angel-cakes-owner-jen-angel-2/\n"
+ "</a></li>\n"
+ "<li><a href=\"\" target=\"_blank\">\n"
+ "Tobacco – New York, NY – Armed Robbery\n"
+ "https://citizen.com/-NOIfeXowunwknAhxrL3\n"
+ "</a></li>\n"
+ "<li><a href=\"\" target=\"_blank\">\n"
+ "Vape – Lincoln, NE – Burglary\n"
+ "https://www.1011now.com/2023/02/14/police-investigating-burglary-northeast-lincoln-vape-shop/\n"
+ "</a></li>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}