$re = '/(?:www\.|(?:https?|ftp|news|file):\/\/)[-A-Z0-9+&@#\/%?=~_|!:,.;]*[-A-Z0-9+&@#\/%=~_|]/i';
$str = 'bla1 bla2 http://www.peckale.com/#!contact/c11m6 bla3 www.peckale.com/#!contact/c11m6, www.peckale.com/#!contact/c11m6!
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);