const regex = /\s*<parent>\n\s*<groupId>com\.ps\.consul\.releng<\/groupId>\n\s*<artifactId>com\.ps\.consul\.releng<\/artifactId>\n\s*<version>1\.0\.0-SNAPSHOT<\/version>\n\s*<relativePath>\.\.\/com\.ps\.consul\.releng<\/relativePath>\n\s*<\/parent>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*<parent>\\n\\s*<groupId>com\\.ps\\.consul\\.releng<\\\/groupId>\\n\\s*<artifactId>com\\.ps\\.consul\\.releng<\\\/artifactId>\\n\\s*<version>1\\.0\\.0-SNAPSHOT<\\\/version>\\n\\s*<relativePath>\\.\\.\\\/com\\.ps\\.consul\\.releng<\\\/relativePath>\\n\\s*<\\\/parent>', '')
const str = ` <parent>
<groupId>com.ps.consul.releng</groupId>
<artifactId>com.ps.consul.releng</artifactId>
<version>1.0.0-SNAPSHOT</version>
<relativePath>../com.ps.consul.releng</relativePath>
</parent>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}