$re = '/^(?<Beleg>[A-Z,0-9]{5,6}).(?<Kontierung>[0-9]{3,5}.[0-9]{3}.[0-9]{2}-[0-9]{2}).(?<Datum>[0-9]{2}.[0-1]{1}[0-9]{1}.[0-9]{2}).(?<VS>[0-9]{3}).(?<US>[0-9]{3})?.(?<UmsatzSoSpace>.?.?.?.?.?.?.?.?.?.?.?.?.?.?.?.?.?)(?<UmsatzSo>[0-9]{0,1}?[0-9]{0,1}?.?[0-9]{0,3}?.?[0-9]{0,3}?.?[0-9]{0,3}?.?[0-9]{0,1}?[0-9]{0,1}?[0-9]{1}?,[0-9]{2}).(?<UmsatzHaSpace>.?.?.?.?.?.?.?.?.?.?.?.?.?.?.?.?)(?<UmsatzHa>[0-9]{0,1}?.?[0-9]{0,3}?.?[0-9]{0,3}?.?[0-9]{0,3}?.?[0-9]{0,1}?[0-9]{0,1}?[0-9]{1}?,[0-9]{2}).(?<GK>[0-9]{2}).(?<Buchungstext>[(\w)(\W)(\s)]{53}).(?<MwSt>[0-9]{0,4}).(?<E_Nr>[0-9]{5})/m';
$str = 'TA9876 10648.000.69-99 04.04.99 999 445,00 0,00 01 Hausgeld WE 23 HAUSG. 19 17847';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);