$re = '/([1-9]+) of ([0-9]+)/';
$str = '5 of 10 pictures converted.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);