# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Original title: (.*)"
test_str = ("\n"
"Conversation opened. 1 read message.\n\n"
"Skip to content\n"
"Using Animateka Mail with screen readers\n"
"prints@animateka.si\n"
"Search\n\n\n\n"
"Click here to enable desktop notifications for Animateka Mail. Learn more Hide\n"
"Mail\n"
"COMPOSE\n"
"Labels\n"
"Inbox\n"
"Starred\n"
"Sent Mail\n"
"Katja\n"
"Smail\n"
"Submissions\n"
"More \n"
" \n"
" More \n"
"21 of 22 \n"
" \n"
"Print all In new window\n"
"Prijavnica\n"
"Inbox\n"
"x \n\n"
"website@animateka.si\n"
"Jul 6 (3 days ago)\n\n"
"to misak \n"
"I apply with my film to the following competition programme:: CENTRAL AND EASTERN EUROPEAN COMPETITION SHORT ANIMATED FILMS\n"
"Original title: Menagerie\n"
"English title: Menagerie\n"
"Running time: 03:28\n"
"Animation Technique: pencil and pen on paper\n"
"Screening format: HD file\n"
"Production year: 2014\n"
"Country: Canada\n"
"Suitable for children: 0\n"
"Age group: 3\n"
"Original language: english / no dialogue\n"
"Subtitles: no dialogue\n"
"Producer: Vancouver Film School\n"
"Distributer: Julian Gallese\n"
"Director: Julian Gallese\n"
"Name: Julian Gallese\n"
"Script: Julian Gallese\n"
"Address: 320 abbott street\n"
"Design: Julian Gallese\n"
"City: Vancouver\n"
"Animation: Julian Gallese\n"
"ZIP: V6B 2K9\n"
"Editing: Rob Wood\n"
"Country: Canada\n"
"Music: Lee Hutzulak\n"
"Phone: 7788295169\n"
"Sound: Julian Gallese\n"
"Email: juliangallese@gmail.com\n"
"SHORT SYNOPSIS: A bird in the water is dreaming about a forest, an ocean liner and himself. Then the tide drifts him to a strange shore.\n"
"SHORT BIOGRAPHY AND FILMOGRAPHY OF THE DIRECTOR: Julian is an artist born in 1992. The unknown is his recurrent theme. His work is a constant exploration of the subconscious. His drawings and storytelling brings up the absurd, in an approach that honours irrationality over technique.\n"
"filmography: menagerie (2014), untitled (2014)\n"
"Previous festival screenings and awards: - Escala humana, Des Pacio art gallery\n"
"- Spike & Mike's festival of Animation\n"
"- Athens Animfest '15\n"
"- Dum-D Student Animation Festival\n"
"- Future Film Festival, Italy\n"
"- Fest Anča International Animation Festival, Slovakia\n"
"Selection preview copy of the film: 1\n"
"Online film submission: 1\n"
"Link: https://vimeo.com/115080765\n"
"I, the undersigned, acknowledge and agree:: 1, 1\n"
"By checking the option(s) bellow, I agree:: 1, 2, 3\n"
"I have read:: 1\n\n"
"---\n\n"
"http://www.animateka.si/2015/tl_files/upload/stillframe_lq.jpg\n"
"http://www.animateka.si/2015/tl_files/upload/screenshot3.jpg\n"
"http://www.animateka.si/2015/tl_files/upload/julian-6.jpg\n"
" \n"
"Click here to Reply, Reply to all, or Forward\n"
"0.08 GB (0%) of 15 GB used\n"
"Manage\n"
"Program Policies\n"
"Powered by Google\n"
"Last account activity: 27 minutes ago\n"
"Details\n\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.