$re = '/^(1[0-2]|0[1-9]|\d)\/([2-9]\d[1-9]\d|[0-9]\d)$/';
$str = '12/99';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);