re = /^.+?@(?=[a-z0-9-]{0,61}\.[a-z]{2,})/m
str = 'user:pass@zxuz.com
user@proxy.brew.opendnstest.com/customBlockUserInfo
user:@proxy.brew1.opendnstest.com/customBlockUserInfo
user:password@proxy.brew2.opendnstest.com/customBlockUserInfo
ftp://cnn.example.com&story=breaking_news@foobar.com/top_story.htm'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end