#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)^(?<atributo>(?<pai>(?:[^=.\n]+)\.?){1,6})=(?<valor>(?:[^=\n]+))$"
Local $sString = "php.environment.ini.session-name = sisicmbio" & @CRLF & _
"php.environment.ini.session-cookie_domain = icmbio.gov.br" & @CRLF & _
"php.environment.ini.session-auto_start = false" & @CRLF & _
"php.environment.ini.session-cookie_path = /" & @CRLF & _
"php.environment.ini.session-cookie_lifetime = 10800" & @CRLF & _
"php.environment.ini.session-cookie_httponly = true" & @CRLF & _
"php.environment.ini.session-use_only_cookie = true" & @CRLF & _
"php.environment.ini.session-gc_maxlifetime = 10800" & @CRLF & _
"php.environment.ini.session-cache_expire = 180" & @CRLF & _
"" & @CRLF & _
";; [php server mail]" & @CRLF & _
"php.mail.sender = smtp" & @CRLF & _
"php.mail.from = notifica@domain.gov.br ; conta default usada para enviar mensagens" & @CRLF & _
"php.mail.replyTo = reposta@domain.gov.br ; conta usada para reply" & @CRLF & _
"php.mail.wordWrap = 60" & @CRLF & _
"php.mail.priority = 3 ; 1: high, 3: normal, 5: low" & @CRLF & _
"php.mail.encoding = 8bit ; 8bit, 7bit, binary, base64, quoted-printable" & @CRLF & _
"php.mail.charset = utf-8" & @CRLF & _
"php.mail.contentType = text/html"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")