package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(Brian)`)
var str = `Brian
Brian
Brian`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}