$re = '/\b(0?[1-9]|[12][0-9]|3[01])\b-(Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)/mi';
$str = 'ALL CHANGES WILL BE EFFECTIVE COB 4-Jun (START OF TRADING 27-Jun) 04-JUN 32-May';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);