#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^[A-Za-z][A-Za-z0-9\.\-\_]+$)|(^[\w\-\.\+]+@([\w-]+\.)+[\w-]{2,4}$)"
Local $sString = "User1.2.3" & @CRLF & _
"simpleuser123" & @CRLF & _
"simpleuser_123" & @CRLF & _
"simpleuser-123" & @CRLF & _
"1baduser" & @CRLF & _
".baduser" & @CRLF & _
"_baduser" & @CRLF & _
"1bob-is.great_999+456@gmail.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")