re = /(?:^| )TC(?:$|12)/m
str = '0110062021110509 TC12116100000433583782810703D277C9A543200210020 0 0 00722310028175541 5492614542504 00000000000 5 5492613030447 4 02613030447 3110219434 543200210020 3110219434 5 1 0 10 703D277C9A10062021105125 0 0 5492613030447 5 2000 0 17 131072 1006202110512610062021105132 10062021105221 0 1310 000049 00 62 0 0 0 04C10780E0DC1E00543200610020 5 1 0 0 16384722 310 722 310 2 0 X360'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end