import Foundation
let pattern = #"^(?<fldrMnemonic>.{2,8}?)_(?<fldrIsbn>\d{13})_(?<fldrComponentPrimaryId>all|tx\d{0,3}|lay\d{0,3}|c0\d{1,3}|c[^0]\d{1,2}?)_(?<fldrComponentSecondaryId>(\d{1,2}|x)p)(?:_r(?<fldrRevisionNumber>\d+))? Folder\/Links\/(?<artFileName>.+?)(?:_r(?<revisionNumber>\d+))?\.(?<extension>jpg|jpeg|psd|psb|tif|tiff|ai|eps|pdf|sct|bmp|ps)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Obam_9781524763138_all_0p_r3 Folder/Links/apple.pdf
Obam_9781524763138_all_0p_r3 Folder/Links/apple_r1.pdf
Obam_9781524763138_all_0p_r3 Folder/Links/001_apple_r1.pdf
Obam_9781524763138_all_0p_r3 Folder/Links/001_apple.pdf
Obam_9781524763138_all_0p_r3 Folder/Links/Obam_9781524763138_all_0p_r3.pdf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)