package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(http|https|ftp):\/\/(\S*)`)
var str = `The test has some url in the last. extract the text starting from https to the end of the string<br></br>https://xyz.com/index.html some text after http://www.ex.com/test.html there are still more text as like ftp://ftp.test.com , which is also matching`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}