# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?'group1'[\d])/$1 & /gm;t' <<< "101011010
110101101
111010110
111101011
011110101
101111010
110111101
011011110
001101111
100110111
110011011
111001101
111100110
011110011
001111001
100111100
010011110
001001111
100100111
010010011
001001001
000100100
000010010
000001001
000000100
000000010
100000001"