re = /(<([^>]+)>)/i
str = '<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<title>Document</title>
</head>
<body>
<div>
Sono un div
<p>Sono un paragrafo </p>
<p>Altro paragrafo </p>
<span>Uno span </span>
<a href="">Un link </a>
<button>Un bottone </button>
</div>
</body>
</html>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end