# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^[#].*\n*(*SKIP)(*F)|
# Version 1 (substitution: '$1$2\n'):
# Match 1-80 characters, backtracking as necessary until whitespace or
# EOL is reached. If words > 80 characters (w/o whitespace) are found,
# no wrapping is performed on that word.
# [1353 steps]
#(.{1,80})(?:\s|$)|(\S{81,})(?:\s|$)
# Version 2 (substitution: '$1$2\n'):
# Same as Version 1 but with a negative look-ahead at the front to skip
# to the alternate branch sooner.
# [773 steps]
#(?!\S{81})(.{1,80})(?:\s|$)|(\S{81,})(?:\s|$)
# Version 3 (substitution: '$1$2\n'):
# Same as Version 1 but alternations swapped.
# [749 steps]
#(\S{81,})(?:\s|$)|(.{1,80})(?:\s|$)
# Version 4 (substitution: '$1\n'):
# Combine alternations into one group.
# [712 steps]
(\S{79,}|.{1,80})(?:\s|$)
"""
test_str = ("THE SOFTWARE IS PROVIDED \"AS IS\" AND THE AUTHOR DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.\n\n\n"
"#### The following should remain on the same line (not wrap):\n\n"
"# Multiple words whose total character+whitespace count <= 80\n"
"123 5678 0 23 5678 012 45678 0 2345 789 12345 78901 3456 8901 3 56 89 12345 7890\n\n"
"# 78-character word followed by 1-character word\n"
"123456789012345678901234567890123456789012345678901234567890123456789012345678 1\n\n"
"# 1-character word followed by 78-character word\n"
"1 345678901234567890123456789012345678901234567890123456789012345678901234567890\n\n\n"
"#### The following should wrap to the next line:\n\n"
"# 45x 4-character words with 2 spaces between each.\n"
"1234 7890 3456 9012 5678 1234 7890 3456 9012 5678 1234 7890 3456 9012 5678 1234 7890 3456 9012 5678 1234 7890 3456 9012 5678 1234 7890 3456 9012 5678 1234 7890 3456 9012 5678 1234 7890 3456 9012 5678 1234 7890 3456 9012 5678\n\n"
"# 79-character word followed by 1-character word\n"
"1234567890123456789012345678901234567890123456789012345678901234567890123456789 1\n\n"
"# 1-character word followed by 79-character word\n"
"1 3456789012345678901234567890123456789012345678901234567890123456789012345678901\n\n"
"# 80-character words followed by >80-character words:\n"
"12345678901234567890123456789012345678901234567890123456789012345678901234567890 123456789012345678901234567890123456789012345678901234567890123456789012345678901 12345678901234567890123456789012345678901234567890123456789012345678901234567890\n"
"1234567890123456789012345678901234567890123456789012345678901234567890123456789012\n")
subst = "$1\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.VERBOSE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.