import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[\\w\\d\\.-_])+@(?=.{4,64}$)(?:[\\w\\d]+[-]?[\\w\\d]+\\.|[\\w\\d]\\.)+(?:\\w{2,})$";
final String string = "q1.3bb@12345678901234567.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}