package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+\@\w+\.(com|ru|net)`)
var str = `mail@mail.com `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}