# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([^\v\t]+)\s*([^\v\t]+)\s*([^\v\t]+)([\v\t]+|Loading transaction details for|[\v\t]+\1){0,3}"
test_str = ("\n"
"Google\n"
"- negative$4.99\n"
"Jun 21Automatic Payment\n"
"Google\n"
"- negative$4.99\n"
"Jun 21Automatic Payment\n"
"Loading transaction details for\n"
"Google\n"
"- negative$4.99\n"
"Jun 21Automatic Payment\n")
subst = "\\1\\2\\3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.