using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""Status"":(""?)(?<cstatus>.*?)(""?),.*?""ProblemFlag"":(""?)(?<probflag>.*?)(""?),.*?""IncreasePending"":(""?)(?<increasePend>.*?)(""?),.*?""SafePay"":(""?)(?<safepay>.*?)(""?),""PastDue"":(""?)(?<pastdue>.*?)(""?),""LastPmtAmt"":(""?)(?<lastpayamt>.*?)(""?),""NextPmtAmt"":(""?)(?<nextpayamt>.*?)(""?),""LastPayDate"":(""?)(?<lastpaydate>.*?)(""?),""NextDebitDate"":(""?)(?<nextdbtdate>.*?)(""?),""AddendumDate"":(""?)(?<addendmdate>.*?)(""?)}";
string input = @"{""Status"":""AP"",""ProblemFlag"":""0"",""IncreasePending"":""1"",""SafePay"":""1"",""PastDue"":""0"",""LastPmtAmt"":""0.00"",""NextPmtAmt"":""453.00"",""LastPayDate"":"",""NextDebitDate"":""2021-02-28 00:00:00"",""AddendumDate"":""2021-02-15 00:00:00""}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}