$re = '/^\p{L}+\.\p{L}+\.\p{L}+$/u';
$str = 'index.home.raft';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);