use strict;
my $str = ' \'https://www.amazon.com/Technology-Ventures-Enterprise-Thomas-Byers/dp/0073523429\',
\'http://www.interactivedynamicvideo.com/\',
\'http://www.nytimes.com/2007/11/07/movies/07stein.html?_r=0\',
\'http://evonomics.com/advertising-cannot-maintain-internet-heres-solution/\',
\'http://github.com/keppel/pinn\',
\'http://phys.org/news/2015-09-scale-solar-youve.html\',
\'https://iot.seeed.cc\',
\'http://www.bfilipek.com/2016/04/custom-deleters-for-c-smart-pointers.html\',
\'http://beta.crowdfireapp.com/?beta=agnipath\',
\'https://www.valid.ly?param\',
\'http://css-cursor.techstream.org\'';
my $regex = qr/https?://([\w+\-\.]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}