re = /(?#digits)(?<zipcode_digits>\d{4})[\s]?(?#chars)(?<zipcode_chars>\w{2})/i
str = '1851 KW'
# Print the match result
str.match(re) do |match|
puts match.to_s
end