$re = '/\s*No further distribution of this document is allowed without approval by the CEO or CFO MMR Policy Test\s*/im';
$str = 'No further distribution of this document is allowed without approval by the CEO or CFO MMR Policy Test asdfsdNo further distribution of this document is allowed without approval by the CEO or CFO MMR Policy Testasdfasd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);