re = /^((?:https?\:\/\/|www\.)(?:facebook)(?:.com\/)(?:[-a-z0-9]+\.)*[-a-z0-9]+.*?)$/i
str = 'http://facebook.com/hahahaha'
# Print the match result
str.match(re) do |match|
puts match.to_s
end