import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "div id=^(.*)><";
final String string = "<div style=\"outline: 1px solid blue;\" class=\"_36bx _4-u2 _4-u8\" data-testid=\"react-composer-root\" id=\"u_0_18\" data-reactid=\".4\"><div class=\"_4d6h _4p1p _4-u3 _57d8\" data-reactid=\".4.0\"><div class=\"clearfix\" data-reactid=\".4.0.0\"><div class=\"_ohe lfloat\" data-reactid=\".4.0.0.$left\"><div data-reactid=\".4.0.0.$left.0\"><a class=\"_5qtm _5qtn\" role=\"tab\" aria-selected=\"true\" label=\"Statut\" icon=\"[object Object]\" data-testid=\"status-attachment-selector\" selected=\"\" href=\"#\" data-reactid=\".4.0.0.$left.0.0\"><span class=\"_4-fs\" data-reactid=\".4.0.0.$left.0.0.0\"><i class=\"_5qto img sp_QiW5hJ5PiNH sx_49d0b1\" data-reactid=\".4.0.0.$left.0.0.0.0\"></i><span class=\"_5qtp\" data-reactid=\".4.0.0.$left.0.0.0.1\">Statut</span><span class=\"_5qtq\" data-reactid=\".4.0.0.$left.0.0.0.2\"></span></span></a><a class=\"_5qtm\" role=\"tab\" aria-selected=\"false\" label=\"Photo/vidéo\" icon=\"[object Object]\" data-testid=\"media-attachment-selector\" href=\"#\" data-reactid=\".4.0.0.$left.0.1\"><span class=\"_4-fs\" data-reactid=\".4.0.0.$left.0.1.0\"><i class=\"_5qto img sp_QiW5hJ5PiNH sx_33bc4c\" data-reactid=\".4.0.0.$left.0.1.0.0\"></i><span class=\"_5qtp\" data-reactid=\".4.0.0.$left.0.1.0.1\">Photo/vidéo</span><span class=\"_5qtq\" data-reactid=\".4.0.0.$left.0.1.0.2\"></span></span></a><a class=\"_5qtm\" role=\"tab\" aria-selected=\"false\" label=\"Offre, évènement +\" icon=\"[object Object]\" href=\"#\" data-reactid=\".4.0.0.$left.0.2\"><span class=\"_4-fs\" data-reactid=\".4.0.0.$left.0.2.0\"><i class=\"_5qto img sp_BaO-9AbAyUH sx_98a590\" data-reactid=\".4.0.0.$left.0.2.0.0\"></i><span class=\"_5qtp\" data-reactid=\".4.0.0.$left.0.2.0.1\">Offre, évènement +</span><span class=\"_5qtq\" data-reactid=\".4.0.0.$left.0.2.0.2\"></span></span></a></div></div><div class=\"_ohf rfloat\" data-reactid=\".4.0.0.$right\"><div data-reactid=\".4.0.0.$right.0\"><img class=\"_4d6i img\" src=\"https://static.xx.fbcdn.net/rsrc.php/v2/yb/r/GsNJNwuI-UM.gif\" data-reactid=\".4.0.0.$right.0.0\" height=\"11\" width=\"16\"><span data-reactid=\".4.0.0.$right.0.1\"><span class=\"hidden_elem _5gvy img _55ym _55yn _55yo _5d9-\" aria-label=\"Chargement...\" aria-busy=\"true\" data-reactid=\".4.0.0.$right.0.1.0\"></span><span class=\"_6vh _4w4v\" data-reactid=\".4.0.0.$right.0.1.1\"><span class=\"hidden_elem _3-8_ img _55ym _55yn _55yo _5d9-\" aria-label=\"Chargement...\" aria-busy=\"true\" data-reactid=\".4.0.0.$right.0.1.1.0\"></span><span aria-label=\"Vous publiez en tant que Mega drole\" data-hover=\"tooltip\" data-reactid=\".4.0.0.$right.0.1.1.1\"><a aria-haspopup=\"true\" aria-owns=\"js_i\" style=\"max-width:200px;\" class=\"_4z8- _55pi _2agf _4z8- _55pi _4jy0 _4jy3 _517h _51sy _59pe _42ft\" href=\"#\" type=\"button\" data-reactid=\".4.0.0.$right.0.1.1.1.0\"><span class=\"_55pe\" data-reactid=\".4.0.0.$right.0.1.1.1.0.1\"><img src=\"https://fbcdn-profile-a.akamaihd.net/hprofile-ak-xft1/v/t1.0-1/p32x32/1453483_555123727915438_1286693911_n.png?oh=e520e64208f4829f8307cfadce0812e8&oe=56C302F3&__gda__=1456503974_001e2d51c40bce6e62c31d80438f25a9\" class=\"img\" data-reactid=\".4.0.0.$right.0.1.1.1.0.1.0\" height=\"16\" width=\"16\"><span data-reactid=\".4.0.0.$right.0.1.1.1.0.1.1\"></span></span><i alt=\"\" class=\"_3-99 img sp_5_FvgObiY-v sx_593e27\" data-reactid=\".4.0.0.$right.0.1.1.1.0.2\"></i></a></span></span></span></div></div></div></div><div class=\"_4zoz _4-u3\" data-reactid=\".4.1\"><div id=\"js_k\" data-reactid=\".4.1.0\"><div class=\"_1y-n\" data-reactid=\".4.1.0.0\"><div class=\"_1y-o\" data-reactid=\".4.1.0.0.0\"><span class=\"_1y-p\" data-reactid=\".4.1.0.0.0.0\">Faites glisser un lien, des photos ou des vidéos ici</span><span class=\"_1y-q\" data-reactid=\".4.1.0.0.0.1\">Déposer le lien</span><span class=\"_1y-r\" data-reactid=\".4.1.0.0.0.2\">Déposer une photo/vidéo</span><span class=\"_1y-s\" data-reactid=\".4.1.0.0.0.3\">Déposez les photos</span></div></div><div class=\"clearfix\" data-reactid=\".4.1.0.1\"><div class=\"_42k7 _4bl7\" data-reactid=\".4.1.0.1.$0\"><div class=\"_3hvt\" data-reactid=\".4.1.0.1.$0.0\"><img class=\"_bth img\" src=\"https://fbcdn-profile-a.akamaihd.net/hprofile-ak-xft1/v/t1.0-1/p40x40/1453483_555123727915438_1286693911_n.png?oh=531ded5fcd4f71ed763f8c6d683325a5&oe=568FDCAF&__gda__=1456525306_54b153b26c9b3c2c6a3ac05ebc0242d6\" data-reactid=\".4.1.0.1.$0.0.0\" height=\"40\" width=\"40\"></div></div><div class=\"_4bl9\" data-reactid=\".4.1.0.1.$1\"><div class=\"_1mwp _1mwq _5bu_ _5yk1\" data-reactid=\".4.1.0.1.$1.0\"><div class=\"_5yk2\" tabindex=\"-2\" data-reactid=\".4.1.0.1.$1.0.0\"><div class=\"_5yw9\" data-reactid=\".4.1.0.1.$1.0.0.0\"><div class=\"_5ywb _5ywc\" data-reactid=\".4.1.0.1.$1.0.0.0.0\"><div class=\"_3br6\" data-reactid=\".4.1.0.1.$1.0.0.0.0.0\">Écrivez quelque chose...</div></div><div class=\"_5ywa\" data-reactid=\".4.1.0.1.$1.0.0.0.$editor0\"><div aria-autocomplete=\"list\" aria-expanded=\"false\" aria-haspopup=\"false\" aria-owns=\"js_j\" class=\"_54-z\" role=\"combobox\" spellcheck=\"true\" title=\"Écrivez quelque chose...\" data-reactid=\".4.1.0.1.$1.0.0.0.$editor0.0\" contenteditable=\"true\"><div data-contents=\"true\" data-reactid=\".4.1.0.1.$1.0.0.0.$editor0.0.0\"><div data-block=\"true\" data-offset-key=\"cioa-0-0\" class=\"_209g _2vxa\" data-reactid=\".4.1.0.1.$1.0.0.0.$editor0.0.0.$cioa\"><span data-offset-key=\"cioa-0-0\" data-reactid=\".4.1.0.1.$1.0.0.0.$editor0.0.0.$cioa.0:$cioa-0-0\"><br data-reactid=\".4.1.0.1.$1.0.0.0.$editor0.0.0.$cioa.0:$cioa-0-0.0\"></span></div></div></div></div></div></div></div></div></div><noscript data-reactid=\".4.1.0.2\"></noscript><div class=\"_3qg0\" data-reactid=\".4.1.0.4\"></div><div data-reactid=\".4.1.0.7\"><div class=\"_5f24\" data-reactid=\".4.1.0.7.0\"><noscript data-reactid=\".4.1.0.7.0.1\"></noscript><noscript data-reactid=\".4.1.0.7.0.2\"></noscript><noscript data-reactid=\".4.1.0.7.0.3\"></noscript></div><div class=\"_2dck _4-u3 _57d8\" data-reactid=\".4.1.0.7.1\"><div class=\"clearfix\" data-reactid=\".4.1.0.7.1.0\"><div class=\"_ohe lfloat\" data-reactid=\".4.1.0.7.1.0.$left\"><div class=\"_47gt\" data-reactid=\".4.1.0.7.1.0.$left.0\"><div class=\"_3xem _3xen\" data-reactid=\".4.1.0.7.1.0.$left.0.0\"><div class=\"_m _6a\" data-reactid=\".4.1.0.7.1.0.$left.0.0.0\"><a rel=\"ignore\" data-hover=\"tooltip\" aria-label=\"Ajoutez des photos à votre publication\" class=\"_3xen _50hp\" data-reactid=\".4.1.0.7.1.0.$left.0.0.0.0\"><span class=\"accessible_elem\" data-reactid=\".4.1.0.7.1.0.$left.0.0.0.0.0\">Ajoutez des photos</span><div class=\"_3jk\"><input id=\"js_l\" aria-label=\"Ajoutez des photos à votre publication\" multiple=\"\" name=\"composer_photo\" role=\"button\" tabindex=\"0\" class=\"_n _5f0v\" data-reactid=\".4.1.0.7.1.0.$left.0.0.0.1\" type=\"file\"></div></a></div></div><a data-hover=\"tooltip\" class=\"_3xem\" aria-label=\"Ajoutez ce que vous faites ou votre humeur\" tabindex=\"0\" role=\"button\" data-reactid=\".4.1.0.7.1.0.$left.0.2\"><span class=\"accessible_elem\" data-reactid=\".4.1.0.7.1.0.$left.0.2.0\">Ajoutez ce que vous faites ou votre humeur</span><div class=\"_3xen _3vk5\" data-reactid=\".4.1.0.7.1.0.$left.0.2.1\"></div></a><a data-hover=\"tooltip\" class=\"_3xem\" aria-label=\"Ajoutez un lieu à votre publication\" tabindex=\"0\" role=\"button\" data-reactid=\".4.1.0.7.1.0.$left.0.3\"><span class=\"accessible_elem\" data-reactid=\".4.1.0.7.1.0.$left.0.3.0\">Identifier un lieu</span><div class=\"_3xen _52xx\" data-reactid=\".4.1.0.7.1.0.$left.0.3.1\"></div><noscript data-reactid=\".4.1.0.7.1.0.$left.0.3.2\"></noscript></a><a data-hover=\"tooltip\" class=\"_3xem\" aria-label=\"Définir la date et l’heure de votre publication\" tabindex=\"0\" role=\"button\" data-reactid=\".4.1.0.7.1.0.$left.0.4\"><span class=\"accessible_elem\" data-reactid=\".4.1.0.7.1.0.$left.0.4.0\">Définir la date et l’heure de votre publication</span><div class=\"_3xen _2czx\" data-reactid=\".4.1.0.7.1.0.$left.0.4.1\"></div></a></div></div><div class=\"_ohf rfloat\" data-reactid=\".4.1.0.7.1.0.$right\"><div class=\"_2ph- _4-u3\" data-reactid=\".4.1.0.7.1.0.$right.0\"><button aria-label=\"Mettez votre publication en avant pour atteindre plus de monde\" data-hover=\"tooltip\" data-testid=\"boosted_post_button_with_id\" class=\"_4dyi _4jy0 _4jy3 _517h _51sy _42ft\" type=\"submit\" value=\"1\" data-reactid=\".4.1.0.7.1.0.$right.0.0:$boosted_post_button\"><span class=\"_4m40\" data-reactid=\".4.1.0.7.1.0.$right.0.0:$boosted_post_button.1\">Mettre en avant</span></button><div class=\"_51xa\" data-reactid=\".4.1.0.7.1.0.$right.0.2\"><button class=\"_1mf7 _4jy0 _4jy3 _4jy1 _51sy selected _42ft\" data-testid=\"react-composer-post-button\" type=\"submit\" value=\"1\" data-reactid=\".4.1.0.7.1.0.$right.0.2.0\"><span data-reactid=\".4.1.0.7.1.0.$right.0.2.0.1\">Publier</span></button><div class=\"_lde uiPopover _6a _6b\" data-reactid=\".4.1.0.7.1.0.$right.0.2.1\"><button role=\"button\" class=\"_p _4jy0 _4jy3 _4jy1 _51sy selected _42ft\" type=\"submit\" value=\"1\" data-reactid=\".4.1.0.7.1.0.$right.0.2.1.$/=10\"><i class=\"img sp_5_FvgObiY-v sx_a9190d\" data-reactid=\".4.1.0.7.1.0.$right.0.2.1.$/=10.2\"></i></button></div></div></div></div></div></div></div></div><noscript data-reactid=\".4.1.1\"></noscript><noscript data-reactid=\".4.1.2\"></noscript><noscript data-reactid=\".4.1.$QUESTION\"></noscript><noscript data-reactid=\".4.1.$QANDA\"></noscript></div></div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}