package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w{8}-\w{4}-\w{4}-\w{4}-\w{12}`)
var str = `data/vms/uuid=1a874c81-9e38-4c4f-bcfa-1b52094f2c8b/flavor/ram_mib`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}