$re = '/ (?=
({%.if
(?:
(?>
(?:
(?! {%.if | endif.%}) .
)+
)*
| (?1)
)*
endif.%})
)
(?1)/xsm';
$str = 'not interested in
{% if something %}
----------------
{% if something %}
DEEPER
{% endif %}
{% irgendwas %}
{% if something %}
DEEPER
{% if something %}
DEEPEST
{% endif %}
DEEPER
{% endif %}
---- endif ----
{% endif %}
not interested in
{% if otherthing %}
++++++++++++++++
{% if something %}
DEEPER
{% endif %}
{% irgendwas %}
{% if something %}
DEEPER
{% if something %}
DEEPEST
{% endif %}
DEEPER
{% endif %}
++++ endif ++++
{% endif %}
not interested in';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);