package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<start>xmlns\:)(?<data>.*?)$`)
var str = `xmlns:mes`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}