package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w\-\.]+@([\w-]+\.)+[\w-]{2,}$`)
var str = `corsec@kimiafarma.co.id
kangoedin@gmail.com
boss@id.abbott`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}