$re = '/^[a-zA-Z]{3}/i';
$str = 'TOM123';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);