$re = '/^(\d+)\s(\w+)\s[deavc]{2,4}\s([a-zA-Zéèàâô.\-\' ]+)\s(\d{4})\s([a-zA-Zéèàâô ]+)\sà\s([\d,.]+)\seuro\s[lae]*\s?([a-zA-Z ]*)$/mu';
$str = '14 cbo de 6 blles de Château Mouton Rothschild 2009 Pauillac à 550 euro la blle
2 cbo de 3 blles de Château Mouton Rothschild 2009 Pauillac à 550 euro la blle
10 cbo de 12 blles de Château Mouton Rothschild 2011 Pauillac à 360 euro la blle
1 cbo de 6 blles de Petit Mouton 2010 Pauillac à 125 euro la blle
35 cbo de 6 blles de Petit Mouton 2010 Pauillac à 160 euro la blle
15 cbo de 6 blles de Château Latour 2010 Pauillac à 1190 euro la blle
1 cbo de 6 magnums de Château Latour 2010 Pauillac à 2450 euro le magnum
3 cbo de 1 double magnum de Château Latour 2010 Pauillac à 4900 euro le double magnum
1 cbo de 6 blles de Château Lafite Rothschild 2012 Pauillac à 370 euro la blle
53 cbo de 6 blles de Carruades de Lafite 2010 Pauillac à 185 euro la blle
17 cbo de 12 blles de Château d\'Armailhac 2011 Pauillac à 31 euro la blle
10 cbo de 6 blles de Château d\'Armailhac 2011 Pauillac à 31 euro la blle
22 cbo de 6 blles d\'Echo de Lynch Bages 2010 Pauillac à 28 euro la blle
1 cbo de 12 blles d\'Echo de Lynch Bages 2010 Pauillac à 28 euro la blle
8 cbo de 12 blles de Echo de Lynch Bages 2012 Pauillac à 22,80 euro la blle
4 cbo de 12 blles de Château Pichon Baron 2011 Pauillac à 70 euro la blle
2 cbo de 6 blles de Château Pichon Comtesse 2012 Pauillac à 70 euro la blle
23 cbo de 12 blles de Château Pontet Canet 2011 Pauillac à 68 euro la blle
1 cbo de 6 blles de Château Grand Puy Ducasse 2003 Pauillac à 29 euro la blle
1 cbo de 6 blles de Château Grand Puy Ducasse 2007 Pauillac à 24 euro la blle
3 cbo de 6 blles de Château Grand Puy Ducasse 2009 Pauillac à 30 euro la blle
2 cbo de 6 blles de Château Beychevelle 2008 Saint Julien à 69 euro la blle
8 cbo de 12 blles de Château Branaire Ducru 2009 Saint Julien à 52 euro la blle
5 cbo de 12 blles de Ch. Leoville Poyferré 2012 Saint julien à 48 euro la blle
5 cbo de 12 blles de Château Leoville Las Cases 2011 Saint julien à 105 euro la blle
11 cbo de 6 blles de Château Leoville Las Cases 2011 Saint julien à 105 euro la blle
15 cbo de 12 blles de Clos du Marquis 2009 Saint Julien à 39 euro la blle
10 cbo de 12 blles de Clos du Marquis 2010 Saint Julien à 38 euro la blle
2 cbo de 12 blles de Clos du Marquis 2011 Saint Julien à 32,50 euro la blle
1 cbo de 12 blles de Château Gruaud Larose 2004 Saint Julien à 42 euro la blle
1 cbo de 12 blles de Château Gruaud Larose 2008 Saint Julien à 45 euro la blle
2 cbo de 12 blles de Sarget de Gruaud 2011 Saint Julien à 15 euro la blle
7 cbo de 6 blles de Sarget de Gruaud 2011 Saint Julien à 15 euro la blle
4 cartons de 6 blles de Sarget de Gruaud 2011 Saint Julien à 15 euro la blle
6 cbo de 12 blles de Château Saint Pierre 2008 Saint julien à 34 euro la blle
1 cbo de 12 blles de Château Saint Pierre 2012 Saint julien à 37 euro la blle
3 cbo de 12 blles de Château Calon Ségur 1995 Saint Estéphe à 78 euro la blle
4 cbo de 12 blles de Château Montrose 2012 Saint Estéphe à 65 euro la blle
3 cbo de 6 blles de la Dame de Montrose 2009 Saint Estéphe à 37 euro la blle
1 cbo de 12 blles de Pagodes de Cos 2008 Saint Estéphe à 28 euro la blle
4 cbo de 12 blles de Pagodes de Cos 2009 Saint Estéphe à 45 euro la blle
17 cbo de 12 blles de Ch. Haut Marbuzet 2009 Saint Estéphe à 30 euro la blle
25 cbo de 12 blles de Ch. Haut Marbuzet 2010 Saint Estéphe à 30 euro la blle
6 cbo de 12 blles de Château Cantenac Brown 2009 Margaux à 42 euro la blle
18 cbo de 12 blles de Château Cantenac Brown 2010 Margaux à 39 euro la blle
3 cbo de 6 blles de Château d\'Issan 2009 Margaux à 49 euro la blle
7 cbo de 12 blles de Château d\'Issan 2010 Margaux à 51 euro la blle
8 cbo de 12 blles de Château d\'Issan 2011 Margaux à 34 euro la blle
18 cbo de 12 blles de Château Giscours 2010 Margaux à 45 euro la blle
4 cbo de 6 blles de Ch. Malescot St Exupéry 2006 Margaux à 37 euro la blle
8 cbo de 12 blles de Château Malescot Saint Exupéry 2010 Margaux à 60 euro la blle
6 cbo de 12 blles de Château Brane Cantenac 2010 Margaux à 57 euro la blle
1 cbo de 6 blles de Domaine de Chevalier 2009 Pessac Léognan à 53 euro la blle
1 cbo de 12 blles de Domaine de Chevalier 2011 Pessac Léognan à 34 euro la blle
1 cbo de 12 blles de Château Haut Bailly 2010 Pessac Léognan à 98 euro la blle
10 cbo de 12 blles de Château Haut Bergey 2008 Pessac Léognan à 16 euro la blle
15 cbo de 6 blles de Château Haut Bergey 2008 Pessac Léognan à 16 euro la blle
22 cbo de 12 blles de Château Haut Bergey 2010 Pessac Léognan à 20 euro la blle
10 cbo de 6 blles de Château Haut Bergey 2010 Pessac Léognan à 20 euro la blle
9 cbo de 6 blles de Château Malartic Lagravière 2009 Pessac Léognan à 33 euro la blle
15 cbo de 6 blles de Château Malartic Lagravière 2012 Pessac Léognan à 22 euro la blle
2 blles de Château Angelus 2009 Saint Emilion à 290 euro la blle
1 cbo avec 10 blles de Château Angelus 2010 Saint Emilion à 270 euro la blle
1 cbo avec 5 blles de Château Ausone 2002 Saint Emilion à 415 euro la blle
1 cbo de 6 blles de Château Ausone 2009 Saint Emilion à 1200 euro la blle
2 cbo de 6 blles de Château Ausone 2010 Saint Emilion à 1280 euro la blle
3 cbo de 6 blles de Château Ausone 2011 Saint Emilion à 560 euro la blle
2 cbo de 6 blles de Château Ausone 2012 Saint Emilion à 450 euro la blle
1 cbo avec 5 blles de La Chapelle d\'Ausone 2009 Saint Emilion à 190 euro la blle
1 cbo avec 5 blles de La Chapelle d\'Ausone 2010 Saint Emilion à 190 euro la blle
1 cbo avec 11 blles de La Chapelle d\'Ausone 2007 Saint Emilion à 110 euro la blle
2 cbo de 12 blles de Ch. Beausejour Duffau 2002 Saint Emilion à 34 euro la blle
1 cbo de 12 blles de Ch. Beausejour Duffau 2003 Saint Emilion à 38 euro la blle
1 cbo de 12 blles de Ch. Beausejour Duffau 2011 Saint Emilion à 52 euro la blle
1 cbo de 6 blles de Ch. Beausejour Duffau 2011 Saint Emilion à 52 euro la blle
5 cbo de 12 blles de Ch. Beausejour Duffau 2012 Saint Emilion à 60 euro la blle
3 cbo de 12 blles de Château La Gaffelière 2009 Saint Emilion à 62 euro la blle
3 cbo de 12 blles de Château La Gaffelière 2010 Saint Emilion à 62 euro la blle
1 cbo de 12 blles de Château Figeac 2009 Saint Emilion à 175 euro la blle
1 cbo de 9 blles de Château Pavie 2002 Saint Emilion à 205 euro la blle
8 cbo de 6 blles de Château Pavie Macquin 2009 Saint Emilion à 65 euro la blle
20 cbo de 6 blles de Château Pavie Macquin 2010 Saint Emilion à 82 euro la blle
2 cbo de 6 blles de Château Pavie Macquin 2012 Saint Emilion à 42 euro la blle
1 cbo de 12 blles de Château Pavie Macquin 2012 Saint Emilion à 42 euro la blle
1 cbo avec 8 blles de Ch. Troplong Mondot 2009 Saint Emilion à 102 euro la blle
1 cbo de 12 blles de Château Le Carré 2008 Saint Emilion à 50 euro la blle
1 cbo de 12 blles de Château Les Astéries 2008 Saint Emilion à 60 euro la blle
1 cbo avec 10 blles de Château Le Dôme 2008 Saint Emilion à 85 euro la blle
1 cbo avec 11 blles de Château Monbousquet 2007 Saint Emilion à 34 euro la blle
1 cbo avec 9 blles de Château Monbousquet 2008 Saint Emilion à 34 euro la blle
3 cbo de 12 blles de Château Lucia 2009 Saint Emilion à 30 euro la blle
9 cbo de 6 blles de Clos Dubreuil 2012 Saint Emilion à 60 euro la blle
10 cbo de 6 blles de Château de Valandraud 2012 Saint Emilion à 92 euro la blle
19 cbo de 6 blles de Virginie de Valandraud 2012 Saint Emilion à 25 euro la blle
1 cbo de 6 blles de Château La Mondotte 2012 Saint Emilion à 140 euro la blle
39 cbo de 6 blles de Château Clinet 2010 Pomerol à 105 euro la blle
3 cbo de 12 blles de Château Gazin 2012 Pomerol à 52 euro la blle
25 cbo de 12 blles de Château La Tour Carnet 2012 Haut Medoc à 19 euro la blle
4 cbo de 12 blles de Roc de Cambes 2010 Côtes de Bourg à 50 euro la blle
22 cbo de 6 blles de Roc de Cambes 2011 Côtes de Bourg à 41 euro la blle
2 cartons de 12 blles de Gevrey Chambertin En Champs 2007 Denis Mortet à 79 euro la blle
7 carton de 12 blles de Gevrey Chambertin 2010 DenisMortet à 55 euro la blle
8 carton de 12 blles de Gevrey Chambertin VV 2010 Denis Mortet à 59 euro la blle
35 cbo de 1 blle de Château Mouton Rothschild 2012 Pauillac à 300 euro la blle
1 cbo de 6 blles de Petit Mouton 2010 Pauillac à 125 euro la blle
15 cbo de 6 blles de Petit Mouton 2011 Pauillac à 117 euro la blle
4 cbo de 6 blles de Petit Mouton 2012 Pauillac à 117 euro la blle
17 cbo de 12 blles de Château d\'Armailhac 2011 Pauillac à 31 euro la blle
10 cbo de 6 blles de Château d\'Armailhac 2011 Pauillac à 31 euro la blle
1 cbo de 12 blles de Château d\'Armailhac 2012 Pauillac à 29 euro la blle
1 cbo avec 11 blles de Château Clerc Milon 2007 Pauillac à 36 euro la blle
30 cbo de 6 blles de Château Clerc Milon 2012 Pauillac à 47 euro la blle
1 cbo de 6 blles de Château Lafite Rothschild 2012 Pauillac à 370 euro la blle
1 cbo de 6 blles de Carruades de Lafite 2010 Pauillac à 155 euro la blle
10 blles de Carruades de Lafite 2011 Pauillac à 128 euro la blle
35 cbo de 6 blles de Carruades de Lafite 2013 Pauillac à 129 euro la blle
11 cbo de 6 blles de Château Lynch Bages 2010 Pauillac à 108 euro la blle
2 cbo de 12 blles de Château Lynch Bages 2010 Pauillac à 108 euro la blle
2 cbo de 6 blles de Château Lynch Bages 2011 Pauillac à 78 euro la blle
90 cbo de 3 blles de Château Lynch Bages 2012 Pauillac à 74 euro la blle
22 cbo de 6 blles d\'Echo de Lynch Bages 2010 Pauillac à 28 euro la blle
1 cbo de 12 blles d\'Echo de Lynch Bages 2010 Pauillac à 28 euro la blle
8 cbo de 12 blles de Echo de Lynch Bages 2012 Pauillac à 22,80 euro la blle
5 cbo de 6 blles de Château Pichon Comtesse 2012 Pauillac à 70 euro la blle
13 cbo de 6 blles de Château Haut Bages Averous 2007 Pauillac à 23 euro la blle
5 cbo de 6 blles de Château Lynch Moussas 2009 Pauillac à 27 euro la blle
4 cbo de 12 blles de Château Grand PuyLacoste 2006 Pauillac à 40 euro la blle
1 cbo de 12 blles de Château Grand PuyLacoste 2009 Pauillac à 61 euro la blle
160 cbo de 6 blles de Château Beychevelle 2012 Saint Julien à 52 euro la blle
20 cbo de 6 blles de Château Beychevelle 2013 Saint Julien à 48 euro la blle
15 cbo de 6 blles de Clos du Marquis 2006 Saint Julien à 36 euro la blle
2 cbo de 6 blles de Château Ducru Beaucaillou 2010 Saint Julien à 165 euro la blle
1 cbo de 12 blles de Château Gruaud Larose 2004 Saint Julien à 42 euro la blle
1 cbo de 12 blles de Château Gruaud Larose 2008 Saint Julien à 45 euro la blle
30 cbo de 6 blles de Château Gruaud Larose 2012 Saint Julien à 37 euro la blle
1 cbo de 6 blles de Château Leoville Las Cases 2007 Saint Julien à 105 euro la blle
1 cbo de 1 Impérial de Château Leoville Las Cases 2007 Saint Julien à 900 euro
40 cbo de 6 blles de Château Talbot 2010 Saint Julien à 46 euro la blle
20 cbo de 6 blles de Château Saint Pierre 2006 Saint julien à 36 euro la blle
6 cbo de 12 blles de Château Saint Pierre 2008 Saint julien à 34 euro la blle
1 cbo de 12 blles de Château Saint Pierre 2012 Saint julien à 37 euro la blle
13 cbo de 6 blles de Château Calon Ségur 2012 Saint Estéphe à 60 euro la blle
4 cbo de 6 blles de Château Lafon Rochet 2006 Saint Estéphe à 28 euro la blle
20 cbo de 6 blles de Château Lafon Rochet 2010 Saint Estéphe à 28 euro la blle
2 cbo de 6 blles de Château Margaux 2012 Margaux à 340 euro la blle
6 cbo de 12 blles de Château Brane Cantenac 2010 Margaux à 57 euro la blle
20 cbo de 6 blles de Château Brane Cantenac 2012 Margaux à 35 euro la blle
50 cbo de 12 blles de Dame de Malescot 2006 Margaux à 23 euro la blle
2 cbo de 12 blles de Château Palmer 2006 Margaux à 148 euro la blle
5 cbo de 12 blles de Château Palmer 2009 Margaux à 250 euro la blle
1 cbo de 12 blles de Château Palmer 2010 Margaux à 250 euro la blle
12 cbo de 12 blles d\'Alter Ego 2010 Margaux à 53 euro la blle
1 cbo de 6 blles d\'Alter Ego 2010 Margaux à 53 euro la blle
10 cbo de 6 blles d\'Alter Ego 2011 Margaux à 45 euro la blle
1 cbo de 12 blles d\'Alter Ego 2011 Margaux à 45 euro la blle
20 cbo de 6 blles d\'Alter Ego 2012 Margaux à 49 euro la blle
15 cbo de 6 blles de Château Les Carmes Haut Brion 2012 Pessac Leognan à 39 euro la blle
12 cbo de 6 blles de Domaine de Chevalier 2012 Pessac Léognan à 34 euro la blle
18 cbo de 12 blles de Château Haut Bailly 2007 Pessac Léognan à 42 euro la blle
8 cbo de 12 blles de Château Haut Bailly 2012 Pessac Léognan à 55 euro la blle
45 cbo de 1 blle de Château Haut Brion 2012 Pessac Leognan à 300 euro la blle
8 cbo de 6 blles de Château Haut Brion 2012 Pessac Leognan à 305 euro la blle
50 cbo de 6 blles de Château Pape Clément 2012 Pessac Léognan à 58 euro la blle
8 cbo de 6 blles de Clémentin de Pape Clément 2009 Pessac Léognan à 27 euro la blle
18 cbo de 6 blles de Ch. Smith Haut Lafitte 2012 Pessac Leognan à 50 euro la blle
8 cbo de 12 blles de Ch. Smith Haut Lafitte 2013 Pessac Leognan à 45 euro la blle
2 blles de Château Angélus 2009 Saint Emilion à 290 euro la blle
1 cbo de 12 blles de Château Angélus 2011 Saint Emilion à 195 euro la blle
6 cbo de 12 blles de Château Figeac 2012 Saint Emilion à 60 euro la blle
10 cbo de 6 blles de Château Figeac 2012 Saint Emilion à 60 euro la blle
50 cbo de 12 blles de Château Monbousquet 2012 Saint Emilion à 28 euro la blle
2 blles de Château Pavie 2008 Saint Emilion à 185 euro la blle
5 cbo de 6 blles de Château La Conseillante 2012 Pomerol à 75 euro la blle ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);