package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(e([0-9])r([0-9]{1,2})p([0-9]{1,2}))`)
var str = `e3r13p23.42.fr`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}