package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^[a-zA-Z][\w]*)\s+(\d+)\s?-\s?(\d+)?\s?\/?\s?(\d+|\*)?`)
var str = `bytes 0-10/200`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}