$re = '/\b[A-Z]{1}\S+/';
$str = '
Thieu Thi Tham oCtham tungTham
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);