$re = '/\d+\.\d+/m';
$str = '123.22
2.2
87.1
123.123
3334
33355
1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);