using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d{2,}):(\d{2}):(\d{2,}):(\d{2,}\.?\d*)$";
string input = @"11:22:33
11:22:33:44
11:22:33:444.4444
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}