import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Caín Daniel Romano Sánchez 35 Masculino (Ecuador) San Pablo de Manta.";
final String string = "Caín Daniel Romano Sánchez 35 Masculino Ecuador San Pablo de Manta\n"
+ "Darío Cristiano Hernandez Martinez 15 Masculino Bolivia Sacaba\n"
+ "Emily Alessia Bianco Sutori 15 Femenino Francia Burdeos\n"
+ "Luis Hilario Hamasaki Schneider 57 Masculino Francia Arles\n"
+ "Valentin Roberto Rodriguez Rinaldi 43 Masculino Ecuador Santiago de Guayaquil\n"
+ "Ruby Olivia Johnson Gutierrez 38 Femenino Bolivia Sucre\n"
+ "Khushi Florence López Messina 50 Femenino Francia París\n"
+ "Tiburcio Pacifico Feraud Brown 23 Masculino Brasil Rio de Janeiro\n"
+ "Carla Martina Santoro Fernandez 9 Femenino Bolivia Guayaramerín\n"
+ "Emma Antonella Williams Himura 43 Femenino Ecuador San Pedro de Riobamba\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}