re = /^(?=.*?[A-Z])(?=.*?[a-z])(?=.*?[0-9])(?=.*?[#?!@$%^&*-]).{8,}$/
str = 'abcdfdadadaghi1A#'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end