# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s*<script src=\"\/((\w+)[\w.\/]+)\"><\/script>"
test_str = ("<!DOCTYPE html>\n"
"<html>\n\n"
"<head>\n"
" <meta charset=\"utf-8\">\n"
" <meta http-equiv=\"Content-Security-Policy\" content=\"default-src * data: gap: https://ssl.gstatic.com; style-src * 'unsafe-inline'; script-src * 'unsafe-inline' 'unsafe-eval'\">\n"
" <meta name=\"viewport\" content=\"width=device-width,initial-scale=1.0\">\n"
" <title>atomic-project</title>\n"
"</head>\n\n"
"<body>\n"
" <div id=\"app\"></div>\n"
" <!-- built files will be auto injected -->\n\n"
"<script src=\"/app.js\"></script><script src=\"/app.js\"></script><script src=\"/app.js\"></script><script src=\"/app.js\"></script></body>\n\n"
"</html>\n")
subst = "\\n<script>\\n const $2Script = document.createElement('script');\\n $2Script.type = 'text/javascript';\\n $2Script.async = true;\\n $2Script.src = '$1';\\n document.body.appendChild($2Script);\\n</script>\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.