#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<NewMarket sysname="SOCCER(.*?)ODD_EVEN"
Local $sString = "<NewMarket sysname="SOCCER_CORNERS_FIRST_HALF_DOUBLE_CHANCE" name="1st Half Corners Double Chance" voidRule="false" settleRule="[Period] >= [HT]">" & @CRLF & _
" <Mappings>" & @CRLF & _
" <OldMarket sysname="SOCCER_CORNERS_HALFTIME_DOUBLE_CHANCE" />" & @CRLF & _
" </Mappings>" & @CRLF & _
" <MarketDefinition captionEn="1st Half Corners Double Chance" captionEl="Διπλή Ευκαιρία Κόρνερ Ημιχρόνου">" & @CRLF & _
" <Odds>" & @CRLF & _
" <Bet code="1X" name="HomeDraw" captionEn="{HomeTeam} / Draw" settleRule="[HomeCorners1H] >= [AwayCorners1H]" />" & @CRLF & _
" <Bet code="X2" name="DrawAway" captionEn="{AwayTeam} / Draw" settleRule="[HomeCorners1H] <= [AwayCorners1H]" />" & @CRLF & _
" <Bet code="12" name="HomeAway" captionEn="{HomeTeam} / {AwayTeam}" settleRule="[HomeCorners1H] > [AwayCorners1H] || [HomeCorners1H] < [AwayCorners1H]" />" & @CRLF & _
" </Odds>" & @CRLF & _
" </MarketDefinition>" & @CRLF & _
" </NewMarket>" & @CRLF & _
" <NewMarket sysname="SOCCER_CORNERS_ODD_EVEN" name="Corners Odd/Even" voidRule="false" settleRule="[Period] >= [FT]">" & @CRLF & _
" <Mappings>" & @CRLF & _
" <OldMarket sysname="SOCCER_CORNERS_ODD_EVEN" />" & @CRLF & _
" </Mappings>" & @CRLF & _
" <MarketDefinition captionEn="Match Corners Odd/Even" captionEl="Μονά Ή Ζυγά Κόρνερ Αγώνα">" & @CRLF & _
" <Odds>" & @CRLF & _
" <Bet code="1" name="Odd" captionEn="Odd" settleRule="([TotalCorners] % 2) = 1" />" & @CRLF & _
" <Bet code="0" name="Even" captionEn="Even" settleRule="([TotalCorners] % 2) = 0" />" & @CRLF & _
" </Odds>" & @CRLF & _
" </MarketDefinition>" & @CRLF & _
" </NewMarket>" & @CRLF & _
" <NewMarket sysname="SOCCER_CORNERS_FIRST_HALF_ODD_EVEN" name="1st Half Corners Odd/Even" voidRule="false" settleRule="[Period] >= [HT]">" & @CRLF & _
" <Mappings>" & @CRLF & _
" <OldMarket sysname="SOCCER_CORNERS_FIRST_HALF_ODD_EVEN" />" & @CRLF & _
" </Mappings>" & @CRLF & _
" <MarketDefinition captionEn="1st Half Odd/Even Corners" captionEl="Μονά Ή Ζυγά Κόρνερ 1ου Ημιχρόνου">" & @CRLF & _
" <Odds>" & @CRLF & _
" <Bet code="1" name="Odd" captionEn="Odd" settleRule="([TotalCorners1H] % 2) = 1" />" & @CRLF & _
" <Bet code="0" name="Even" captionEn="Even" settleRule="([TotalCorners1H] % 2) = 0" />" & @CRLF & _
" </Odds>" & @CRLF & _
" </MarketDefinition>" & @CRLF & _
" </NewMarket>" & @CRLF & _
" <NewMarket sysname="SOCCER_CORNERS_SECOND_HALF_ODD_EVEN" name="2nd Half Corners Odd/Even" voidRule="false" settleRule="[Period] >= [FT]">" & @CRLF & _
" <Mappings>" & @CRLF & _
" <OldMarket sysname="SOCCER_CORNERS_SECOND_HALF_ODD_EVEN" />" & @CRLF & _
" </Mappings>" & @CRLF & _
" <MarketDefinition captionEn="2nd Half Odd/Even Corners" captionEl="Μονά Ή Ζυγά Κόρνερ 2ου Ημιχρόνου">" & @CRLF & _
" <Odds>" & @CRLF & _
" <Bet code="1" name="Odd" captionEn="Odd" settleRule="([TotalCorners2H] % 2) = 1" />" & @CRLF & _
" <Bet code="0" name="Even" captionEn="Even" settleRule="([TotalCorners2H] % 2) = 0" />" & @CRLF & _
" </Odds>" & @CRLF & _
" </MarketDefinition>" & @CRLF & _
" </NewMarket>" & @CRLF & _
" <NewMarket sysname="SOCCER_CORNERS_RESULT_NO_DRAW" name="Corners Draw No Bet" voidRule="[Period] >= [FT] && [HomeCorners] = [AwayCorners]" settleRule="[Period] >= [FT] && [HomeCorners] != [AwayCorners]">" & @CRLF & _
" <Mappings>" & @CRLF & _
" <OldMarket sysname="SOCCER_CORNERS_RESULT_NO_DRAW" />" & @CRLF & _
" </Mappings>" & @CRLF & _
" <MarketDefinition captionEn="Match Corners Draw no bet" captionEl="Νικητής Κόρνερ Αγώνα Ισοπαλία ΄Οχι Στοίχημα">" & @CRLF & _
" <Odds>" & @CRLF & _
" <Bet code="1" name="Home" captionEn="{HomeTeam}" settleRule="[HomeCorners] > [AwayCorners]" />" & @CRLF & _
" <Bet code="2" name="Away" captionEn="{AwayTeam}" settleRule="[HomeCorners] < [AwayCorners]" />" & @CRLF & _
" </Odds>" & @CRLF & _
" </MarketDefinition>" & @CRLF & _
" </NewMarket>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")